Tidiest Method For A Device Dependent Use Of The Standard Combobox plugin

  • I want to use the combo box plugin for scene selection but not on small screen devices.

    The method I have been thinking of is a device dependent import for instance

    <include url=\"real_combo.xml\" devices=\"desktop\" />
    <include url=\"dummy_combo.xml\" devices=\"iphone\" />

    The real_combo.xml would contain code for the regular flash/js plugin.

    <plugin name="cb" url="combobox.swf" alturl="combobox.js" etc etc >

    The dummy_combo.xml would as the name suggests just contain a minimal non-functional, non-visible plugin provided to keep the
    code tidy something like

    <plugin name="cb" url="" alturl="" visible="false" enabled="false" etc etc >

    The code in my main file contains statements to update the combo box currently selected item if another method ( say a hotspot ) is
    used to change the scene, otherwise the combo box would get out of step.

    <action name="startscene">
    plugin[cb].selectIdItem( item10 ); plugin[cb].closeList();" : "" ) .
    </action>

    In the above example plugin[cb] is the combo box and item10 is the position of the new scene in the combo box list.

    If the startscene code is to be unconditional (that would be simplest) it would be nice to know how to create tidy code so that calling the methods
    selectIdItem() and closeList() on the dummy plugin were not calls to functionality that did not exist - I want the dummy plugin
    defined in dummy_combo.xml to have dummy methods or actions such that calling

    plugin[cb].selectIdItem( item10 )

    Would result in a clean successful call to a defined method/action but the function would merely be a "do nothing" dummy empty function, in otherwords how
    to trivially define a dummy version of the krpano combobox plugin and methods for device dependent purpose.

    This is leading to the question whether krpano actions can be associated or owned by a particular plugin so that we have
    something that looks a little bit like object orientated code ( object (plugin) owns methods (actions) ).

    The "methods" ( actions ) associated with my dummy plugin would not actually do anything they are there only to keep the code tidy and not to
    have untidy loose ends that trigger error warnings.

    Thanks Jon

    Edited 5 times, last by Jonnie (July 7, 2013 at 5:13 PM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!