You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, August 27th 2009, 4:33pm

How to impove graphic display quality in krpano ?

Hello,

When i draw a circle in flash, or photoshop (for a button for example), the circle looks good but when i use it in krpano, it looks very bad. I think it’s a problem like antialiasing. The border of the circle is not clean.
There is no problem with square. I've tried to draw a black circle in flash and the background color is white. I've tried the same in photoshop but the result is the same. When i preview the circle in Flash, it's ok. But not in krpano.

Do you know if there is a parameter in krpano to improve the quality display of the graphics ?

I’m using krpano 1.08 beta and my flash project is flash player 9.

Thank you !

Tuur

Master

Posts: 2,296

Location: Netherlands

Occupation: Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Thursday, August 27th 2009, 5:07pm

Try to skip the scale="..."

or make it scale 1..

that will do..
Tuur *thumbsup*

3

Thursday, August 27th 2009, 5:50pm

Thanx Tuur for your answer.

In fact, scale is already set to 1.
Or there is no scale. I've tried both.

There is always this problem of display.

I create my own plugin in Flash for krpano.

In that plugin, i draw "circle" buttons. When i publish the plugin, the display is quite ok.

But in krpano, the circle are bad.

Attachments : This is 2 screen capture : First one in krpano, 2nd one in flash. Do you notice the difference ?
Vinyl has attached the following images:
  • 01-cicle-buttons-preview-in-krpano.jpg
  • 02-circe-buttons-published-in-flash.jpg

michel

Professional

Posts: 1,153

Location: ANDORRA

Occupation: TV

  • Send private message

4

Thursday, August 27th 2009, 7:31pm

Hi Vinyl,

I have the same display problem on my swf files displayed in Krpano...
The bad display is evident when there is some text in the swf... the text looks very bad.... *sad*
I have tried using smoothing=true parameter in the plugin used to display the swf, without result.
It looks like if the display quality option of flashplayer was set to low ...

Salut

5

Thursday, August 27th 2009, 10:21pm

Hi,

krpano uses for performance reasons the StageQuality MEDIUM when the display quality (movequality10/stillquality10) was set to HIGH,

with StageQuality MEDIUM the Flashplayer uses a 2x2 anti-alias pixel grid and with StageQuality HIGH or BEST a 4x4 grid,

see here:
http://help.adobe.com/en_US/AS3LCR/Flash…ageQuality.html

but for rendering the pano itself NO "edge" anti-alias would be necessary (don't mixup with bitmap filtering!) because all "edges" of the internal triangles are connected, unfortunately there is no way in Flash to disable it, so I used the MEDIUM StageQuality as compromise between Quality and Performance,


if possible I would recommend to use bitmaps instead of vector graphics for best performance,
but you could also set the stage quality to a higher level in your plugin,

e.g. set in your plugin:

Source code

1
stage.quality = StageQuality.BEST;


(I will add a display quality setting for StageQuality.BEST in the next release)

best regards,
Klaus

6

Friday, August 28th 2009, 2:17am

Salut Klaus,

Thanx for your answer and your explanation.
I was looking for a solution since a long time. Didn't think of this parameter.

Source code

1
stage.quality = StageQuality.BEST;


So, thank you, It works !

But :

When i load a plugin in krpano which contains this as3 code :

Source code

1
stage.quality = StageQuality.BEST;


It doesn't work at all. My plugin is out (no buttons, no action).

But when i load a plugin (ex : main.swf) wich contains a button or an action which loads an other plugin (ex : 01.swf) containing

Source code

1
stage.quality = StageQuality.BEST;


it works, no problem, graphic display is ok, plugin works very well.

Do you know why ?


Quoted

if possible I would recommend to use bitmaps instead of vector graphics for best performance,


It's weird, i've tried to use bitmap graphic and the result is worst. It a simple .gif file. It looks perfect in Flash, horrible in krpano. By the way, it works now with vector graphics.

Quoted

(I will add a display quality setting for StageQuality. BEST in the next release)


Great !

This post has been edited 1 times, last edit by "Vinyl" (Aug 28th 2009, 2:58am)


7

Friday, August 28th 2009, 11:38am

Hi,

When i load a plugin in krpano which contains this as3 code :

Source code

1
stage.quality = StageQuality.BEST;


It doesn't work at all. My plugin is out (no buttons, no action).
when do you make this call?
note - the plugin must wait for until it was added to the stage before it can access the stage object!
e.g. do:

Source code

1
2
3
4
5
this.addEventListener(Event.ADDED_TO_STAGE, startplugin);
function startplugin(evt:Event):void
{
 stage.quality = StageQuality.BEST;
}


It's weird, i've tried to use bitmap graphic and the result is worst. It a simple .gif file. It looks perfect in Flash, horrible in krpano. By the way, it works now with vector graphics.
do you scale the bitmap? disabled smoothing? pixel fitting?

best regards,
Klaus

bulp

Intermediate

Posts: 388

Location: Malaysia

  • Send private message

8

Saturday, August 29th 2009, 7:26pm

Thank you Vinyl for bring up this issue... *thumbsup*

i do notice this also.. but didn't think off stage quality issue.. just thinking of the rendering issue that occur when flash10 mode turn off/on..

id just tried this new code... it works.. thank you Klaus... *thumbsup*

maybe all the textfield plugin (or other plugins) also have to set the best quality ever Klaus... just my opinion.. if this kind of setting do have effect into rendering performance better stay the current stage setting...

9

Tuesday, September 1st 2009, 3:23am

Hi !

Quoted

Thank you Vinyl for bring up this issue...


Yes !! Thanx Klaus for the answer ! I It's a really important thing to know ;-)

This as3 code is ok :

Source code

1
2
3
4
5
this.addEventListener(Event.ADDED_TO_STAGE, startplugin);
function startplugin(evt:Event):void
{
 stage.quality = StageQuality.BEST;
}


Quoted

do you scale the bitmap? disabled smoothing? pixel fitting?


Concerning the display of bitmaps, i will make a test soon.

10

Wednesday, September 2nd 2009, 1:20pm

Hi,
maybe all the textfield plugin (or other plugins) also have to set the best quality ever Klaus... just my opinion.. if this kind of setting do have effect into rendering performance better stay the current stage setting...
not that wouldn't be good, the setting will be for the whole flashplayer,
changing the setting for only a plugin or so is not possible!

e.g. when using flash9 the BEST(or HIGH) setting will be very slow compared to the LOW setting!
I already implemented the BEST setting for the next release, when using only cubical faces and no fisheye/stereographic distortion then the rendering performance will be still okay,

best regards,
Klaus

bulp

Intermediate

Posts: 388

Location: Malaysia

  • Send private message

11

Wednesday, September 2nd 2009, 3:52pm

owh... thanks you klaus... *thumbsup*

bulp

Intermediate

Posts: 388

Location: Malaysia

  • Send private message

12

Monday, September 14th 2009, 5:19pm

deleted.

This post has been edited 1 times, last edit by "bulp" (May 27th 2010, 3:50am)


13

Monday, September 14th 2009, 10:03pm

Hi,
1)the quality drop in littleplanet view. i do reset to the normal view with flash10.on the quality drop as in littleplanet view..
right, with flash10 off - the "movequality" and "stillquality" settings are used, and if there are different the stage quality is changed on every move,

2)the stage.quality didnt work (quality drop) in littleplanet view..
yes, because of the continuing changing between move and stillquality,
set both to HIGH and it should work,


maybe on your next release wont have this problems...
yes
then "BEST" can be used for movequality(10) and stillquality(10),

best regards,
Klaus

Tuur

Master

Posts: 2,296

Location: Netherlands

Occupation: Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

14

Monday, February 8th 2010, 6:50pm

Read and done,

but how do i make the panorama move nice and smooth again and why does the plugin reacts slower when the brouwser screen is bigger??

in xml i had a much better performance but you should expect that from as3/flash..


Tuur
*thumbsup*