You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

kimblarsen

Beginner

  • "kimblarsen" started this thread

Posts: 47

Location: Oslo, Norway

Occupation: digital artist, production designer, architect, photographer

  • Send private message

1

Wednesday, November 5th 2008, 4:24pm

wrong krpano version

Hi,

I have recently started playing with the demo version looking at purchasing a license very soon. I have downloaded the 1.0.7 version and got the following error message for both the "editor" button and the "options" button:
wrong krpano version
I have no idea what I have done wrong 8| so help is greatly appreciated, thanks.

Kim Baumann Larsen
Kim Baumann Larsen
Placebo Effects | 3d photo film design

2

Wednesday, November 5th 2008, 6:04pm

Hi,

had you installed an older version before?

because when updating to version 1.0.7 - the krpano.swf and ALL plugin files must be updated (the whole plugin folder),
plugins from the previous version wouldn't work with the new version,

best regards,
Klaus

kimblarsen

Beginner

  • "kimblarsen" started this thread

Posts: 47

Location: Oslo, Norway

Occupation: digital artist, production designer, architect, photographer

  • Send private message

3

Wednesday, November 5th 2008, 11:37pm

Hi Klaus,

No. I have never used krpano before so this was my first attempt at modifying one of the example files and use one of my own panoramas instead.

Kim
Kim Baumann Larsen
Placebo Effects | 3d photo film design

4

Thursday, November 6th 2008, 5:34pm

Hi Kim

this is very strange...
the only possibility when this happens should be when the version of krpano and the version of the plugin differ...

can you mail me your test files?

best regards,
Klaus

5

Friday, November 7th 2008, 9:03am

I'm getting the same result... I took at 1.0.6 tour, replaced all plugins with 1.0.7 plugins (as well as krpano.swf) - the tour will show the editor button. When I click on editor button I get standard 4 options (hotspots, xml, etc.) when I click on hotspots... nothing happens. When I click on XML - the only thing that appears is the BACK button overlaid over what appears to be the Load Original XML button - both in the upper left hand corner. No other editor buttons appear to do anything.

FF 3.0.3, Flash 10.0.12.36

kimblarsen

Beginner

  • "kimblarsen" started this thread

Posts: 47

Location: Oslo, Norway

Occupation: digital artist, production designer, architect, photographer

  • Send private message

6

Friday, November 7th 2008, 11:39am

I got it to work when renaming my pano to the example sphere name and using only the example krpano.swf and krpano.xml files provided; the problem arised as soon as I started playing around with different names on the files.

Kim,
Kim Baumann Larsen
Placebo Effects | 3d photo film design

7

Friday, November 7th 2008, 12:55pm

Hi,

the problems you described show exactly what will happen when using
a older krpano.swf file and newer plugins or a newer krpano.swf and
older plugins,

(have you used the kmakemultires tool to create a pano?
because this tool still have the old krpano.swf 1.0.6 included)

please make sure that all files are up to date,

check the krpano.swf version by starting it and pressing the 'O' key,
it will display the version number in the log window:


also check the filesizes:
krpano.swf - version 1.0.7 - 69kb
krpano.swf - version 1.0.6 - 67kb

to check the plugin version just open/start the plugin:


if you have the standalone flashplayer installed you can open the swf files
just by double clicking,

you can download the standalone players here:

Windows (EXE, 3.69 MB)
http://download.macromedia.com/pub/flash…yer_9_debug.exe

Macintosh (ZIP, 4.81 MB)
http://download.macromedia.com/pub/flash…9_debug.app.zip

Linux (TAR.GZ, 9.29 MB)
http://download.macromedia.com/pub/flash…inux_dev.tar.gz

best regards,
Klaus

8

Saturday, November 8th 2008, 4:42am

I found out that all I had to do was change : <krpano version="1.0.5"> to the correct version <krpano version="1.0.7"> in the krpano.xml - along with switching krpano.swf and the plugins (editor.swf, etc) from 1.0.7...

9

Monday, November 10th 2008, 10:58pm

Hi, still very strange
normaly it should also work without setting version to "1.0.7",
when you press 'O' in the viewer - is "INFO: krpano 1.0.7" displayed?

best regards,
Klaus

10

Friday, August 28th 2009, 2:53pm

Hi, still very strange
normaly it should also work without setting version to "1.0.7",
when you press 'O' in the viewer - is "INFO: krpano 1.0.7" displayed?

best regards,
Klaus
I got the same problem, I know why it happens but don't know how to resolve it. I use Autopano Tour because it allows to avoid coding in some cases. I tried to use plugins from 1.0.7 version but found that Autopano is somehow uses version 1.0.8 beta. Is there any way to make plugin works under Autopano?

11

Wednesday, September 2nd 2009, 10:43am

tried to use plugins from 1.0.7 version but found that Autopano is somehow uses version 1.0.8 beta. Is there any way to make plugin works under Autopano?
Hi,

just use the plugins from 1.0.8 beta
get them here:
http://krpano.com/download/beta/

best regards,
Klaus

Similar threads