You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, July 22nd 2009, 4:31pm

Help needed with file structure!!

I'm still very new to flash and KR pano. I've been trying to make the code a bit neater and have been trying to put EVERYTHING inside one folder titled "360_files" except for the index page and the css. Can someone assist? I keep getting a parsing error or an i/o error. I've added the script from the index page below.

<div id="pano">

<div id="krpanoDIV">
<noscript><table width="754" height="480" border="2" align="center" cellpadding="2" bordercolor="#CCCCCC">
<tr valign="middle" bordercolor="#333333"><td width="754" height="474" align="center" valign="middle" bordercolor="#F0F0F0" bgcolor="#CCCCCC"><center>
<span class="style2">ERROR:<br>
<br>
Javascript not activated</span><br>
<br>
</center></td></tr></table></noscript>
</div>

<script type="text/javascript" src="360_files/swfobject/swfobject.js"></script>
<script type="text/javascript" src="360_files/swfobject/swfkrpanomousewheel.js"></script>

<script type="text/javascript">
// <![CDATA[
if (typeof(deconcept) !== 'undefined')
{
if (deconcept.SWFObjectUtil.getPlayerVersion().major >= 6)
{
var so = new SWFObject("360_files/plugins/krpano.swf", "krpanoSWFObject", "754", "480", "9.0.28","#000000");

so.addParam("allowFullScreen","true");
so.addVariable("license","360_files/license.xml");
so.useExpressInstall("360_files/swfobject/expressinstall.swf");
so.setAttribute("xiRedirectUrl", window.location);

so.addVariable("pano","360_files/esotericvision.xml");

if ( so.write("krpanoDIV") ) { var mousewheelfixes = new SWFkrpanoMouseWheel(so); }
}
else
{
document.getElementById("krpanoDIV").innerHTML = '<table width="100%" height="100%"><tr valign="middle"><td><center>ERROR:<br><br>Adobe Flash Player 9 needed<br><br><br><a href="http://www.adobe.com/go/getflashplayer/" target="_blank"><IMG SRC="http://www.macromedia.com/images/shared/download_buttons/get_flash_player.gif" BORDER="1"></a><br>...click here to download...<br><br><br><br></center></td></tr></table>';
}
}
else
{
document.getElementById("krpanoDIV").innerHTML = '<table width="100%" height="100%"><tr valign="middle"><td><center>ERROR:<br><br><b>./swfobject/swfobject.js</b> not found<br><br><br><br><br></center></td></tr></table>';
}
// ]]>
</script>
</div>

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

2

Thursday, July 23rd 2009, 2:34am

just to clarify... you are getting krpano.swf to load and it's giving you the errors?

3

Monday, July 27th 2009, 2:10am

Help with file structure...please.

Yeah, actually the web developer I gave it to got it to load after changing the file structure to clean it up. He basically did what I described as my goal (to get all the files in one folder except the css and index.html). Everything loads except the thumbs. Here's the link.

http://www.massageheights.com/360_tour.php

Any help is greatly appreciated.

Ben

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

4

Wednesday, July 29th 2009, 6:13am

If the thumbs are not loading... then you might want to post the link here and see if shanti or others can help you out with the specifics.

It's a bit odd that when loading the index file directly (remote window link) the thumbs show up.

It makes me think that there is a path issue... which I can sometimes help with... but in the case of Shanti's plugin, I can't say for sure how it reads the url path in...

Source code

1
       url="plugins/thumbs.swf?TheXML=gallery1.xml"

... if it's relative to the thumbs.swf file or if it's relative to the krpano.swf file.

--------
I just tried loading your page and using the firebug firefox app / plugin... and I don't think it's even trying to load the thumbs.swf... but I can't tell if it just can't find it... or if there's some other error.

Shanti / Klaus and others are more adept at debugging this type of issue... or at least pointing you down the right path.

Sorry I can't help more at this point.... but the thumbs plugin isn't something I've had a chance to really use.

5

Friday, July 31st 2009, 4:05pm

Hi,

the "thumbs.swf" looks for the "gallery1.xml" at this place:

http://www.massageheights.com/gallery1.xml

this is the place of the html (php) file,

best regards,
Klaus