Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 19. März 2012, 22:50

Video läuft nur im Flashviewer und iphone aber nicht auf dem iPad

Liebe Panofreunde ich habe das Problem dass das Ersatzvideo
.mp4 nur auf dem iphone läuft aber auf dem iPad wird
nur das Ersatzbild angezeigt ohne Playbutton?
Woran kann es liegen?
Beste Grüsse

2

Dienstag, 20. März 2012, 20:37

Hi,

dieser automatische 'Play-Button' wird nur auf dem iPhone angezeigt,

hat das Video selbst ein "onclick" Event welches das Video startet?
auf iOS ist das Video zu Beginn immer pausiert, und muss deshalb per Benutzer-Interaktion gestartet werden.

z.B. per:
onclick="play()" - oder - onclick="resume()" - oder - onclick="togglepause();"

Schöne Grüße,
Klaus

3

Mittwoch, 21. März 2012, 11:00

Danke für den Tipp Klaus! Ok onclick play funktioniert! Nun kommt das zweite Problem, ich habe das Videofenster im plugin editor hotspots an die grösse eines Fernseher Bildschirms angepasst..
das klappt einwandfrei unter Flash aber bei iOS/iPad wird nur das das poster.jpeg mit der richtigen Größe angepasst das Videofenster ist aber kleiner.....
Grüsse!

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
<hotspot name="video1" devices="all"
	         url="plugins/videoplayer.swf"
	         keep="false"
	         ath="36.269040934265774" atv="10.688378247673922"
	         zoom="false" distorted="true" details="8" flying="0"
	         width="647" height="364"
	         scale="0.6133891824331863" scale9grid="" scalechildren="true" rotate="0"
	         rx="10" ry="0" rz="2.1657937297489864"
	         edge="center" ox="" oy=""
	         crop="" ondowncrop="" onovercrop=""
	         visible="true" enabled="true" usecontentsize="true" handcursor="true" capture="true" children="true" maskchildren="false"
 	         zorder="0"
	         alpha="1.00" autoalpha="false" blendmode="normal" effect="" smoothing="true" pixelhittest="false"
	         refreshrate="auto"
 	         onloaded=""
	         onover=""
	         onhover=""
	         onout=""
	         ondown=""
	         onup=""
	         onclick="play()"
	         alturl="plugins/videoplayer.js"
	         altvideourl="video/Business-Video-Bose-Videowave-Experience-Center-Wien-fhoch3.mp4"
	         buffertime="0.1"
	         directionalsound="true"
	         iscomplete="false"
	         isvideoready="true"
	         loadedbytes="7142197"
	         loop="true"
	         onunsupported=""
	         onvideocomplete=""
	         onvideopaused=""
	         onvideoready=""
	         outofrangevolume="0"
	         pausedonstart="false"
	         posterurl="video/Business-Video-Bose-Videowave-Experience-Center-Wien-fhoch3.jpg"
	         range="90"
	         rangefalloff="1"
	         totalbytes="7142197"
	         totaltime="66.266"
	         updateeveryframe="true"
	         videourl="video/Business-Video-Bose-Videowave-Experience-Center-Wien-fhoch3.f4v"
	         volume="1"
	         /> 

4

Mittwoch, 21. März 2012, 11:03

Oder hat jemand einen Tipp wie ich die exakte Grösse der Fernseherbildschirmgrösse im Pano herausbekomme um das Video dementsprechend zu berechnen dann muss ich es auch nicht mehr scalen oder....

5

Mittwoch, 21. März 2012, 15:42

Hi,
das klappt einwandfrei unter Flash aber bei iOS/iPad wird nur das das poster.jpeg mit der richtigen Größe angepasst das Videofenster ist aber kleiner.....
das sollte eigentlich nicht passieren...
die Größe wird ja in der XML angegeben, und sollte somit auch immer gleich blieben...

haben das "posterurl" Bild und das Video dieselbe Größe?
ist die krpano Version und das Videoplayer Plugin aktuell?
kannst du eventuell einen Link zu dem Beispiel posten?

Schöne Grüße,
Klaus

7

Mittwoch, 21. März 2012, 23:09

Hi,

das ist kein Fehler im Viewer oder Videoplayer Plugin! Das Videos selbst sind unterschiedlich!
Vergleiche die F4V mit der MP4 einfach einmal in einem normalen Videoplayer (z.B. VLC):

f4v = 646x364
mp4 = 646x484 (= plus schwarzer Rand oben und unten)

Weiters werden Videos in HTML5 vom Browser automatisch immer proportional skaliert/eingepasst, dadurch wirkt das Bild im Endeffekt einfach nur kleiner.

Schöne Grüße,
Klaus

8

Montag, 26. März 2012, 17:48

Danke Klaus!
Jetzt klappts war ein Fehler bei der Umwandlung in mp4 h.264
Meine nächste Herausforderung ist es,
das Video im Flasplayer per Mausclick zu pausieren und dann wieder per Click weiter abzuspielen
ein Problem habe ich noch bei Popupbilder die "darunterliegenden" Hotspots lliegen über bzw. sind im Popupbild sichtbar
lässt sich das durch z order lösen?
Beste Grüße!

9

Donnerstag, 3. Mai 2012, 11:30

wie in mp4 h.264 umwandeln

hallo,
ich stehe auch vor dem problem mit den videos auf dem iphone.
die normalen mp4 laufen da ja nicht.
wie/wo/mit was kann ich die denn umwandeln?
vg
markus

10

Dienstag, 15. Mai 2012, 14:13

Adobe Media Encoder....