Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 29. November 2011, 17:24

Problem with combobox and Internet Explorer

Hi,

my panoramatour:
http://www.print-o-tec.de/panorama_spo/index.html

works fine with every browser but the Internet Explorer on Windows.
When I open it in this browser, the combobox is empty. When I click on the combobox, it only shows two arrows (up and down) but no text.

Here are parts of the code I use:

<!-- combobox plugin -->

<plugin name="box" url="%SWFPATH%/plugins/combobox.swf" alturl="plugins/combobox.js"
preload="true"
keep="true"
align="righttop" x="15" y="15" width="180"
blendmode="layer"
rowcount="6"
onclick="trace(combobox clicked);"
/>

<action name="start">
plugin[box].addIdItem(1, 'EG: Küche', loadscene(eg_kueche,null,MERGE,BLEND(1.5)); );
plugin[box].addIdItem(2, 'OG1: Flur', loadscene(og1_flur,null,MERGE,BLEND(1.5)); );
plugin[box].addIdItem(3, 'OG1: Wohnzimmer', loadscene(og1_wohnzimmer,null,MERGE,BLEND(1.5)); );
plugin[box].addIdItem(4, 'OG1: Badezimmer', loadscene(og1_badezimmer,null,MERGE,BLEND(1.5)); );
plugin[box].addIdItem(5, 'OG1: Kinderzimmer', loadscene(og1_kinderzimmer,null,MERGE,BLEND(1.5)); );
plugin[box].addIdItem(6, 'OG2: Schlafzimmer', loadscene(og2_schlafzimmer,null,MERGE,BLEND(1.5)); );

<!-- load 1. scene on start -->
loadscene(eg_kueche,null,MERGE,BLEND(1.5));


</action>

.......

And here is a scene for example:

<!-- SCENE EG KUECHE -->

<scene name="eg_kueche" >

<preview url="kueche_fertig.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="573" progressive="false">
<level tiledimagewidth="2865" tiledimageheight="2865">
<cube url="kueche_fertig.tiles/l3_%s_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="1433" tiledimageheight="1433">
<cube url="kueche_fertig.tiles/l2_%s_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="717" tiledimageheight="717">
<cube url="kueche_fertig.tiles/l1_%s_%0v_%0h.jpg" />
</level>
<mobile>
<cube url="kueche_fertig.tiles/mobile_%s.jpg" />
</mobile>
<tablet>
<cube url="kueche_fertig.tiles/tablet_%s.jpg" />
</tablet>
</image>

<view vlookat="9.11" hlookat="132.57" fov="85.0" fovmax="90" maxpixelzoom="1.5"/>

<hotspot name="treppehoch" style="hotspot_ani_black"
edge="center"
alpha="0.7"
ath="29"
atv="-1.47"
zoom="true"
onhover="showtext(zum OG1);"
onclick="looktohotspot(treppehoch, 30);
gotoscene(og1_flur);

lookat(97.7,15.22,40,smooth(10,20,50));
lookto(97.7,15.22,85,smooth(10,20,30));"
/>

</scene>

............

Can You help me?
Thanks.

Regards,
Josh