Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 7. Oktober 2011, 12:37

Pano PC toll, Pano iPhone oll

Moin.

Ich bin am verzweifeln! Habe eine VT erstellt und die läuft super! Sowohl auf dem PC als auch iPhone. Nun habe ich es ein wenig ausgeschmückt. Eine Karte eingebunden, mit Radar versehen, alles prima. PC keine Probleme...
Den Code habe ich auch ein wenig aufgelockert, in dem ich mittels include-Anweisungen zwei dateien hinzufüge...

Die erste Datei, formatiert nur den Text der Tooltips. Löft super! *thumbup*
Wenn ich aber mittels include die Datei "map.xml" einlade, die einige actions beinhaltet und plugins, die die Karte positionieren und verschieben und so weiter, dann bekomme ich beim iPhone die Meldung, dass die entsprechende .xml-datei (map.xml) ein "loading or parsing failed" produziert.
Der PC läuft wundervoll!!!!

muss ich für PC und iPhone separierte Dateien erstellen? ohne die Auslagerungen und spielereien klappt alles.

Ich finde keine Lösung und bitte um Hilfe!

LG Morph

Beiträge: 601

Wohnort: Sachsen

Beruf: Webdesigner- und entwickler sowie Fotodesigner

  • Nachricht senden

2

Freitag, 7. Oktober 2011, 17:05

der fehler besagt, dass dein xml code fehlerhaft ist.
öffne mal die betreffende xml datei direkt im firefox - der sollte dir dann rot die fehlerhaften zeilen anzeigen.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

3

Freitag, 7. Oktober 2011, 20:07

Lustiges Teil...

Danke erst einmal für diese tolle Anregung. Und es hat auch in sofern etwas gebracht, dass ich nun noch weniger verstehe als vorher... *unsure* *thumbup*

<textstyle name="tooltip"
^

das ist was er mir ausgibt... davor steht in der xml-datei:
<!-- action definieren -->

<action name="changepano">
loadpano(%1.xml,null,MERGE,BLEND(1));
</action>

ich bin am ende... *cry*

Beiträge: 601

Wohnort: Sachsen

Beruf: Webdesigner- und entwickler sowie Fotodesigner

  • Nachricht senden

4

Freitag, 7. Oktober 2011, 20:29

schau mal textstyle, da sollte der fehler drin sein.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

5

Freitag, 7. Oktober 2011, 20:39

Ich gebe dir mal meine versuchsdatei, die schon mit diesen bischen code völlig abranzt...

<!-- action definieren -->

<action name="changepano">
loadpano(%1.xml,null,MERGE,BLEND(1));
</action>

<textstyle name="tooltip"
font="Arial"
fontsize="12.0"
background="true"
backgroundcolor="0xFFFFCC"
border="true"
bordercolor="0x333333"
textcolor="0x333333"
alpha="0.8"
blendmode="normal"
effect="dropshadow(2,5,0x000000,3,1);"
origin="cursor"
edge="bottom"
textalign="none"
xoffset="0"
yoffset="-3"
showtime="0.1"
fadeintime="0.5"
noclip="true"
/>


und das tolle ist, jedes für sich allein in einer datei passt. zusammen bringt es nen fehler. und wenn du umstellst (action nach unten) dann bringt dir action den fehler... *blink*
ABER auch wenn du das plugin in einer datei hast und danach ein neues plugin aufführst, bekommst du ebenfalls den fehler...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Morpheus1572« (7. Oktober 2011, 20:58)


Beiträge: 601

Wohnort: Sachsen

Beruf: Webdesigner- und entwickler sowie Fotodesigner

  • Nachricht senden

6

Samstag, 8. Oktober 2011, 08:42

Kannst Du evtl. den Link zur Onlinedatei bereitstellen, damit man es im gesamten Kontext prüfen kann?
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

7

Samstag, 8. Oktober 2011, 13:53

jetzt nur die einzelne datei oder das ganze Projekt (also die VT)?

8

Samstag, 8. Oktober 2011, 22:08

gelöst - mehr oder weniger :-)

Hahahaha,

in meinem Tut und in der Doku habe ich das nicht gefunden, ABER:

es ist für SAFARI sehr wichtig, dass included .xml-dateien einen Root-Tag haben. In dem Fall also ein

<krpano>
...
...
...
</krpano>

DARAUF muss man als Anfänger erst mal kommen. *cool* Wer kann schon ahnen, dass SAFARI so "zimperlich" ist? *w00t*

nun habe ich ein neues Problem aber das werde ich separat aufführen. In diesem Sinne: Danke für eure Hilfe. War meine Dummheit!