You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Karotte

Beginner

  • "Karotte" started this thread

Posts: 39

Location: Leipzig

Occupation: Selbständig

  • Send private message

1

Tuesday, September 20th 2011, 2:04pm

xml verschlüsseln - branding free licence

Hallo,

ich möchte für eine Tour die xml Datei verschlüsseln und leider bekomme ich es nicht hin.
Folgendes habe ich versucht:
1. krprotect gestartet, Domain limited ausgewählt und die entsprechende Domain hinzugefügt.
2. Generate Protected File ausgewählt und die entsprechende swf erzeugt
3. Im Reiter Encyption-Tool per Add Files die xml hinzugefügt und Encypt Now gewählt.

Ich habe dann eine verschlüsselte xml, aber meine Tour startet nicht mehr, der Bildschirm bleibt schwarz.

Kann mir bitte jemand erklären wie es funktioniert?

Vielen lieben Dank,
viele Grüße
Marcus

2

Tuesday, September 20th 2011, 3:33pm

Hi,

so wie du es beschrieben hast, ist es im Prinzip schon richtig...

welche krpano Version?
kommt keine Fehlermeldung? einfach nur ein schwarzer Bildschirm?

Schöne Grüße,
Klaus

Karotte

Beginner

  • "Karotte" started this thread

Posts: 39

Location: Leipzig

Occupation: Selbständig

  • Send private message

3

Tuesday, September 20th 2011, 6:30pm

Hallo Klaus,

ich benutze die aktuelle Version aus dem Downloadbereich, habe sie auch nochmal runtergeladen um den Fehler einzuschränken.
Fehlermeldung hab ich auch keine - einfach nur einen schwarzen Bildschirm.

Grüße
Marcus

€: Die Lizenzdateien habe ich alle einfach in den "krpano tools" Ordner kopiert - hoffe das war richtig...

iceman_fx

Professional

Posts: 601

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

4

Tuesday, September 20th 2011, 6:44pm

Aufpassen, es gibt noch einen kleinen Bug dabei, wenn man die erste XML encryptet.
Dann bleibt alles schwarz bzw. es kommt noch der Fehler, dass der XML-Code ungültig wäre.
Lass mal die erste XML-Datei normal und encrypte nur die tieferen.
Das klappt bei mir bestens so, nur halt nicht mit der ersten XML.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

Karotte

Beginner

  • "Karotte" started this thread

Posts: 39

Location: Leipzig

Occupation: Selbständig

  • Send private message

5

Tuesday, September 20th 2011, 6:50pm

Das könnte es schon gewesen sein, ich habe bei dieser Tour nur eine xml.
Ich teste es morgen mal und gebe Bescheid ob dass das Problem war - aber die Chancen stehen gut.

Danke
Marcus

6

Wednesday, September 21st 2011, 12:59pm

Hi,
Aufpassen, es gibt noch einen kleinen Bug dabei, wenn man die erste XML encryptet.
stimmt, es gibt doch einen kleinen Bug mit dem Entschlüsseln, allerdings hat dieser nichts mit der Reihenfolge der XML Dateien zu tun - der Bug hängt mit der internen verschlüsselten Länge der XML Datei zusammen - der verschlüsselte Inhalt wird Base64-kodiert und bei der Base64-Dekodierung im Flash Viewer schlägt die Überprüfung der '=' Zeichen, welche die Länge der dekodierten Datei bestimmen, fehl,

es wird in kürze ein Update mit dem Bugfix geben,

als Workaround für den Moment wäre es möglich, das Verschlüsseln entweder öfters zu versuchen und eventuell dabei auch die Länge der XML Datei zu variieren (z.B. durch einfügen von Leerzeichen) - wenn in der verschlüsselten XML Datei am Ende kein '=' auftritt, dann sollte das Entschlüsseln funktionieren,

bzgl. schwarzer Bildschirm - mit der Branding Free Lizenz werden Fehlermeldung per Default nicht angezeigt, eventuell ist das hier der Grund...

Schöne Grüße,
Klaus

iceman_fx

Professional

Posts: 601

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

7

Wednesday, September 21st 2011, 3:10pm

Da habe ich wahrscheinlich immer den ungünstigen Fall erwischt ;-))
Bisher 4 Projekte encrypted und bei allen ging die erste Datei nicht.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

8

Friday, September 23rd 2011, 12:40pm

Hi,

es gibt eine neue Version, wo dieser Bug behoben ist:
krpano 1.0.8.14

Schöne Grüße,
Klaus