Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Karotte

Anfänger

  • »Karotte« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Leipzig

Beruf: Selbständig

  • Nachricht senden

1

Dienstag, 20. September 2011, 14:04

xml verschlüsseln - branding free licence

Hallo,

ich möchte für eine Tour die xml Datei verschlüsseln und leider bekomme ich es nicht hin.
Folgendes habe ich versucht:
1. krprotect gestartet, Domain limited ausgewählt und die entsprechende Domain hinzugefügt.
2. Generate Protected File ausgewählt und die entsprechende swf erzeugt
3. Im Reiter Encyption-Tool per Add Files die xml hinzugefügt und Encypt Now gewählt.

Ich habe dann eine verschlüsselte xml, aber meine Tour startet nicht mehr, der Bildschirm bleibt schwarz.

Kann mir bitte jemand erklären wie es funktioniert?

Vielen lieben Dank,
viele Grüße
Marcus

2

Dienstag, 20. September 2011, 15:33

Hi,

so wie du es beschrieben hast, ist es im Prinzip schon richtig...

welche krpano Version?
kommt keine Fehlermeldung? einfach nur ein schwarzer Bildschirm?

Schöne Grüße,
Klaus

Karotte

Anfänger

  • »Karotte« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Leipzig

Beruf: Selbständig

  • Nachricht senden

3

Dienstag, 20. September 2011, 18:30

Hallo Klaus,

ich benutze die aktuelle Version aus dem Downloadbereich, habe sie auch nochmal runtergeladen um den Fehler einzuschränken.
Fehlermeldung hab ich auch keine - einfach nur einen schwarzen Bildschirm.

Grüße
Marcus

€: Die Lizenzdateien habe ich alle einfach in den "krpano tools" Ordner kopiert - hoffe das war richtig...

Beiträge: 601

Wohnort: Sachsen

Beruf: Webdesigner- und entwickler sowie Fotodesigner

  • Nachricht senden

4

Dienstag, 20. September 2011, 18:44

Aufpassen, es gibt noch einen kleinen Bug dabei, wenn man die erste XML encryptet.
Dann bleibt alles schwarz bzw. es kommt noch der Fehler, dass der XML-Code ungültig wäre.
Lass mal die erste XML-Datei normal und encrypte nur die tieferen.
Das klappt bei mir bestens so, nur halt nicht mit der ersten XML.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

Karotte

Anfänger

  • »Karotte« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Leipzig

Beruf: Selbständig

  • Nachricht senden

5

Dienstag, 20. September 2011, 18:50

Das könnte es schon gewesen sein, ich habe bei dieser Tour nur eine xml.
Ich teste es morgen mal und gebe Bescheid ob dass das Problem war - aber die Chancen stehen gut.

Danke
Marcus

6

Mittwoch, 21. September 2011, 12:59

Hi,
Aufpassen, es gibt noch einen kleinen Bug dabei, wenn man die erste XML encryptet.
stimmt, es gibt doch einen kleinen Bug mit dem Entschlüsseln, allerdings hat dieser nichts mit der Reihenfolge der XML Dateien zu tun - der Bug hängt mit der internen verschlüsselten Länge der XML Datei zusammen - der verschlüsselte Inhalt wird Base64-kodiert und bei der Base64-Dekodierung im Flash Viewer schlägt die Überprüfung der '=' Zeichen, welche die Länge der dekodierten Datei bestimmen, fehl,

es wird in kürze ein Update mit dem Bugfix geben,

als Workaround für den Moment wäre es möglich, das Verschlüsseln entweder öfters zu versuchen und eventuell dabei auch die Länge der XML Datei zu variieren (z.B. durch einfügen von Leerzeichen) - wenn in der verschlüsselten XML Datei am Ende kein '=' auftritt, dann sollte das Entschlüsseln funktionieren,

bzgl. schwarzer Bildschirm - mit der Branding Free Lizenz werden Fehlermeldung per Default nicht angezeigt, eventuell ist das hier der Grund...

Schöne Grüße,
Klaus

Beiträge: 601

Wohnort: Sachsen

Beruf: Webdesigner- und entwickler sowie Fotodesigner

  • Nachricht senden

7

Mittwoch, 21. September 2011, 15:10

Da habe ich wahrscheinlich immer den ungünstigen Fall erwischt ;-))
Bisher 4 Projekte encrypted und bei allen ging die erste Datei nicht.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

8

Freitag, 23. September 2011, 12:40

Hi,

es gibt eine neue Version, wo dieser Bug behoben ist:
krpano 1.0.8.14

Schöne Grüße,
Klaus