You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

1

Thursday, September 15th 2011, 5:05pm

fade panorama to black and start video

hello my friends,

today i am looking for a special solution to fade a panorama smoothly into a black screen on which then a video should start.

unfortunately on the iPad there is no automatic trigger to run the video so my solution to use two scenes did work on the desktop but not on the ipad. is there a workaround to run the entire scenario in one scene without eating all the resources?

something like an action that could be triggered to fade the pano (or blend a black image over the pano), then "unload" the pano-tiles and then load/run the video? i should be able to get it going if only i knew how its possible how to fade and unload the pano.

haven't tried it yet, but could this be part of the solution?

iceman_fx

Professional

Posts: 598

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

2

Thursday, September 15th 2011, 5:20pm

Hi Jürgen,
you can add a lightbox effect with an 100% plugin.
Set the zorder at 0 and fade it to alpha=1. Now set the zorder of your videoplugin to a higher index.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

3

Thursday, September 15th 2011, 6:15pm

I tried this (which works fine on the desktop) but on the iPad it only loads the posterurl but no video. Even if I tap on it. Why?

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
	<hotspot name="door3"
        url="door3.jpg"
        alturl="door3.jpg"
        distorted="true"
		ath="-90.0" atv="0.0"
		width="130"
		height="344.09"
		edge="lefttop"	
		ox="-37.27"
		oy="-167.73"        
		onclick="looktohotspot(); loadxml(null,null,KEEPALL,blend(2));wait(blend);startvideoscene();"
        />	
	
<plugin name="video"
        url="video/videoplayer.swf"
		visible="false"
        alturl="video/videoplayer.js"
        videourl="video/introroh.m4v"
        altvideourl="video/introroh.m4v"
        posterurl="video/dummy.jpg"
        align="center" x="0" y="0"
        pausedonstart="true"
        loop="false"
        volume="0.0"
        buffertime="0.1"
        updateeveryframe="false"
        onvideoready=""
        onvideocomplete="loadscene(inside)"
        onunsupported=""
		onclick=""
        />
		
	<action name="startvideoscene">
	set(plugin[video].visible,true);
	set(plugin[video].volume,1.0);
	delayedcall(1, plugin[video].resume() );
	</action>

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

4

Thursday, September 15th 2011, 10:37pm

DEALING WITH VIDEO IN PANOS ON THE IPAD IS SOOOO FRUSTRATING !!!!

I've spend the afternoon and almost the whole evening just to find out that it doesn't even seem possible to trigger the start of a video by anything else but tapping on the video itself. Not even from a dedicated hotspot. Only if it once was successfully started with a tap on the video frame other external triggers (as from actions) do have any effect. Can somebody prove this or am I just too stupid?

In either case please send me some enlightenment!

When nothing seemed to work I started from scratch with the example Klaus provided and extended it step by step to match my needs and to figure out at which stage I might have made a mistake. Besides that a paused video doesn't start really paused (there is always a sound for the fraction of a second as soon as the video loads), I then could not find a way to get it started other then described above. Oh, how that sucks, ... please, Honey! ... better get me my pills! ...

Posts: 105

Location: Barcelona

Occupation: VR Photographer

  • Send private message

5

Saturday, October 1st 2011, 6:01pm

DEALING WITH VIDEO IN PANOS ON THE IPAD IS SOOOO FRUSTRATING !!!!


Totally agree!
I'm sorry I can't enlighten you on this subject as I seem to be in a similar place (by the way, what pills work for you?! *smile* ). However, I do have a tip about the sound as the video loads. I always set my video volume at 0 and have an action to set it to 1 at some point after the pano has loaded.

Here's an example from one of my tours. Hope it helps:

<plugin name="video1"
url="hotspots/videoplayer.swf"
alturl="hotspots/videoplayer.js"
videourl="hotspots/vids/terraza.mp4"
altvideourl=""
posterurl=""
scale="0"
align="center" x="120" y="63"
pausedonstart="true"
scalechildren="true"
loop="false"
visible="false"
parent="panel1"
volume="0.0"
buffertime="0.1"
updateeveryframe="false"
onvideocomplete="stopvid1()"
onunsupported="apology1()"
/>

<action name="playvid1">
set(plugin[video1].volume,0.7);
set(plugin[video1].visible,true);
set(plugin[vid1_play].visible,false);
tween(plugin[video1].scale,2.5,0.5);
tween(plugin[video1].x,0,0.5);
tween(plugin[video1].y,0,0.5);
tween(plugin[vid1_shadow].scale,2.49,0.5);
tween(plugin[vid1_shadow].x,0,0.5);
tween(plugin[vid1_shadow].y,0,0.5,,
plugin[video1].play()));
</action>

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

6

Sunday, October 2nd 2011, 12:00pm

The sound problem should be solved with the latest release from Klaus.
Thanks to a great idea from Sacha I found a workaround for the one-tap-starting-problem.
Yesterday I did a test and it worked.
Unfortunately it's really clumsy and one would only use it if in an iPad-tour an instant start is a must.
The trick is to have the video invisibly intergrated using the posterurl and when clicked make it "flying" to release it from rotating with the pano.
I also found that the flying attribute(?) isn't even documented in krpano documentation, one has to look at the flyout more hotspots example to find out about it.

Regarding the pills, it's always good to have plenty of sweets or chocolate around ;)

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

7

Sunday, October 2nd 2011, 8:31pm

One more problem regarding the fade.
I need to fade the panorama to black (without leaving it!) and then start the video.
So I tried an overlaying black image and the video with a higher zorder.
But no matter which zorder the image has, it is always on top and the complete screen is black.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
<hotspot name="video"
        url="video/videoplayer.swf"
		visible="true"
		enabled="true"
		distorted="true"
		 ath="-90.0" atv="0.0"
		 width="290.91"
		 height="163.64"
		 edge="lefttop"
		 ox="-145.45"
		 oy="-81.82"
        alturl="video/videoplayer.js"
        videourl="video/introroh.m4v"
        altvideourl="video/introroh.m4v"
        posterurl="video/door.jpg"
        zorder="99"
		alpha="1"
        pausedonstart="true"
        loop="false"
        volume="0.1"
        buffertime="0.1"
        updateeveryframe="false"
        onvideoready=""
        onvideocomplete=""
        onunsupported=""
		onclick="set(plugin[schwarz].visible,true); tween(plugin[schwarz].alpha,1.0,1,easeoutquad,wait); tween(hotspot[video].flying, 1.0, 0.5, default); tween(hotspot[video].width, 640); tween(hotspot[video].height, 360); tween(hotspot[video].ox, -320);
		tween(hotspot[video].oy, -180); resume(); "
        />

<plugin name="schwarz"
        url="video/schwarz.jpg"
		visible="false"
		enabled="false"
		width="100%"
		height="100%"
		align="center" x="0" y="0"
		alpha="0"
        zorder="0"
        />


And there's even more issues.

This post has been edited 1 times, last edit by "jschrader" (Oct 2nd 2011, 10:51pm)


jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

8

Sunday, October 2nd 2011, 11:46pm

In the meantime I solved this issue by using a black hotspot instead of a plugin.
Which needs a bit more code, but anything else would obviously be too easy - *sigh*.

sachagriffin

Professional

Posts: 1,348

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

9

Monday, October 3rd 2011, 12:09am

you try a zorder of 1 for your overlay?
KRPano Developer: Portfolio :: Facebook :: Twitter

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

10

Monday, October 3rd 2011, 12:39am

Well, I don't think I used 1, but several combinations between -99 and 99.
They didn't work.

sachagriffin

Professional

Posts: 1,348

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

11

Monday, October 3rd 2011, 2:59am

Oh, Ill start my video forays this week so I should have some better insights then. Also I'm pretty sure there is no negative zorder in krpano.
KRPano Developer: Portfolio :: Facebook :: Twitter

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

12

Monday, October 3rd 2011, 6:14am

I found an example on the forum where you used -2 and as I was desperate
I thought it wouldn't hurt to try it :D

iceman_fx

Professional

Posts: 598

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

13

Monday, October 3rd 2011, 8:15am

negative zorder are only available at the flash player
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

jschrader

Intermediate

  • "jschrader" started this thread

Posts: 213

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

14

Monday, October 3rd 2011, 10:05am

But it doesn't work with positive values either.

HansNyb

Professional

Posts: 811

Location: Denmark

Occupation: Photographer

  • Send private message

15

Saturday, December 3rd 2011, 12:16pm

Klaus where are you.

This problem needs attention.
At least you should have start of the video available like with sound when you tap the pano.
I thought I could do it by making a large posterimage which I believed I could cover the full window, but it turned out that it resized to the videosize.

Hans

esys

Intermediate

Posts: 267

Location: Balazé France

Occupation: photographer

  • Send private message

16

Thursday, December 8th 2011, 5:42pm

Hi everybody,
In the meantime I solved this issue by using a black hotspot instead of a plugin.
Which needs a bit more code, but anything else would obviously be too easy - *sigh*.

I did the same thing to display my "flyin-out" pictures which are basically called from a hotspot.
ex 360 (click on the "photo" logo)
What about when you call a black hotspot from a plugin, zorder works in that case ? Did you succeed, i try to do the same thing with a slideshow :
slideshow pro problems

negative zorder are only available at the flash player

Thanks for that, i didn't know that! What then on iOs if i set a zorder="-2" ?


The trick is to have the video invisibly intergrated using the posterurl and when clicked make it "flying" to release it from rotating with the pano.
I also found that the flying attribute(?) isn't even documented in krpano documentation, one has to look at the flyout more hotspots example to find out about it.

Did you succeed ? I'd like to use the "flyin-out" movement for my slideshow. *smile*
Thanks

Steph.
Steph

JPC

Beginner

Posts: 39

Location: Paris

Occupation: Photographies and media

  • Send private message

17

Tuesday, February 28th 2012, 2:20pm

tween volume doesn't work

tween volume from a video doesn't work form at this link, do somebody know why ? thanks


http://www.camus.pro/chauvintest2/chauvintest.html



Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
		<plugin name="spot0object" zorder="2" url="videoplayer.swf"
        alturl="videoplayer.js" pausedonstart="false"   loop="false" keep="true" videourl="spots/Eric_Chauvin_Intro_01.mp4" altvideourl="spots/Eric_Chauvin_Intro_01.mp4" align="center" x="0" y="0" width="100%" height="prop" alpha="1" 
		
		onclick="tween(volume,0.0,2);tween(alpha,0,5);delayedcall(10,set(visible,false))" 
		
		onvideocomplete="tween(alpha,0,5);delayedcall(10,set(visible,false));set(volume,0.5);delayedcall(5,set(volume,0.1));delayedcall(8,set(volume,0.0));" 
		
		
		
		
		capture="false" preload="true"/>
		
		

esys

Intermediate

Posts: 267

Location: Balazé France

Occupation: photographer

  • Send private message

18

Wednesday, February 29th 2012, 12:42am

Hi,

I still to be embarassed with THe black mask hotspot. It works great with a fly in out hotspot picture but i've a thumbnail plugin in the foreground and zorder doesn't work between hotspot and plugin. So user still able to navigate through the thumbs during video! If i put a black plugin, my picture is behind the black mask!

No issue?

I also found that the flying attribute(?) isn't even documented in krpano documentation, one has to look at the flyout more hotspots example to find out about it.


Hi jschrader,

I'd like to fly in my videoplayer through a fly in out hotspot. Is that what you did?

Thanks. *smile*
Steph.
Steph