Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 9. November 2009, 18:56

kann der Videoplayer mit Transparenzen umgehen?

Hallo zusammen,

ist es möglich, Flash-Videos mit einem Alpha-Kanal für Transparenz im Plugin anzeigen zu lassen?

Gruß
Matthias

2

Montag, 9. November 2009, 19:56

Hallo!

Im Prinzip schon aber ich habe unter gewissen umständen damit Darstellungsprobleme (siehe hierzu Beitrag 8 aus folgendem Topic: firefox videoplayer-bug?)

3

Sonntag, 27. Dezember 2009, 11:50

alpha parameter

Hm. Was bedeutet "im Prinzip"? Es gibt beim Videoplayer-Plugin den parameter

alpha="1.00" blendmode="normal" smoothing="true" als Voreinstellung.

Wenn ich ein flv mit Alphakanal verwende, wird der maskierte Bereich schwarz dargestellt. Was muss ich einstellen, damit die Transparenz wirksam wird? Wenn das funktioniert, befasse ich mich dann auch gerne mit den beschriebenen Bugs ;-)

Besten Gruß,
Michael

4

Montag, 28. Dezember 2009, 16:47

Hi,
Wenn ich ein flv mit Alphakanal verwende, wird der maskierte Bereich schwarz dargestellt. Was muss ich einstellen, damit die Transparenz wirksam wird?
wenn ein Video einen Alphakanal enthält, wird dieser automatisch verwendet,
d.h. es muss nichts eingestellt werden...

hast du eventuell ein Beispiel wo es nicht funktioniert?
dann könnte man eventuell mehr dazu sagen...

ein Hinweis aber noch - die h264 Video Kompression unterstützt keinen Alphakanal! vielleicht ist das ja der Fall...


Schöne Grüße,
Klaus

5

Montag, 28. Dezember 2009, 21:15

ein Hinweis aber noch - die h264 Video Kompression unterstützt keinen Alphakanal! vielleicht ist das ja der Fall...
Hallo Klaus,

jupp... das war der entscheidende Hinweis. Komprimierung war zwar Sorensen Spark, aber nachdem ich auf on2 VP6 umgestellt hatte (die beiden Kompressoren, die bei FLV in After Effects überhaupt angeboten werden), hat es geklappt. Danke vielmals!

Michael

6

Dienstag, 29. Dezember 2009, 00:34

So, mal einen kleinen Test fertig gemacht. Ein bisschen Arbeit war die wandernde Alpha-Maske. Die Pano-Qualität ist nur mit 6000x3000 ausgegeben, da könnte ich noch was drehen(war aber nicht mehr geplant) aber geärgert habe ich mich jetzt über die geringe Auflösung des Videos. Hochkant in nur 640x480 statt HD aufgenommen (Panoposition), und nur einen Ausschnitt verwendet. Da wäre also mehr drin gewesen, wenn ich das vorher gewusst hätte.

http://mobilmanie.de/temp/video/videotester.html

Das ganze jetzt noch über einen Hotspot starten und beenden, das wärs dann so etwa.

Gruß,
Michael

7

Donnerstag, 31. Dezember 2009, 00:44

Hi,
jupp... das war der entscheidende Hinweis. Komprimierung war zwar Sorensen Spark
okay, danke gut zu wissen!
in der Flash Dokumentation wird bzgl. nicht unterstütztem Alpha Kanal nur der h264 Codec erwähnt,

Schöne Grüße,
Klaus

8

Dienstag, 17. August 2010, 18:56

Video mit Alphakanal

Hallo,
ich hab das Problem auch, obwohl ich auf on2 VP6 gestellt habe.

Testseite: http://www.kreyenbruecker-muehle.de/pano…html?pano=2_neu

Wer weiss warum ?

Gruß
Clemens

9

Mittwoch, 18. August 2010, 11:18

Hi,

hat das Video einen Alphakanal?
ich kenne momentan leider keine Möglichkeit das festzustellen, aber ich glaube beim Ausgeben muss das immer irgendwie extra ausgewählt werden...

Schöne Grüße,
Klaus

10

Mittwoch, 18. August 2010, 11:30

Hallo Klaus,
die schwarzen Teile sind der Alphakanal.
Gruß
Clemens

11

Mittwoch, 18. August 2010, 11:41

Hi,

ich habe gerade das Video durch das FLVExtract Tool von hier laufen lassen,
dieses sollte laut der Dokumentation dort:

Zitat

Extracts VP6 alpha channel to a separate file.
einen vorhanden Alpha Kanal als extra Datei speichern, tut es aber nicht...

ich vermute deshalb einfach, dass der Alpha Kanal nicht mit gespeichert ist, eine andere Erklärung habe ich eigentlich nicht, Codemäßig kann man hier nichts falsch machen, da die Grafik samt der Transparenz fertig vom Flashplayer kommt,

Schöne Grüße,
Klaus

12

Mittwoch, 18. August 2010, 11:41

jetzt hab ichs, man muss halt nur fragen, dann findet mans auch.
Man muss beim Erstellen der flv Alphakanal kodieren anhaken.

Danke
Gruß
Clemens

moeller-j

Anfänger

Beiträge: 15

Wohnort: ulm

Beruf: Industriedesigner

  • Nachricht senden

13

Montag, 1. November 2010, 17:14

weicher rand für video hotspot

moin,
hört sich gut an.. als ambitionierter anfänger möchte ich
eine animation ins pano einbinden.

arbeitsmodell hier

die farben stimmen soweit nur exakte positionierung geht noch nicht,
und den alpha in aftereffects habich auch noch nicht hinbekommen *unsure*

hebe erstmal eine maske davorgesetzt mit "weichem" alpha rand (ja, geht auf kosten der performance
und funktioniert bei seitlicher ansicht nicht mehr)

frage: kann der video hotspot auch einen rand( border="true") bekommen und
kann der auch "weich einblenden" border = unscharf und durchsichtig ?
oder mussich aftereffects lernen weil einfacher?

grüße