You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

fellipe

Trainee

  • "fellipe" started this thread

Posts: 67

Location: Brazil

Occupation: Photographer

  • Send private message

1

Saturday, June 12th 2010, 5:48pm

Nadirlogo? How to get it working?

I added the following code in my xml file but the nadir img does not show:

<!-- nadir logo (distored hotspot) -->
<hotspot name="nadirlogo"
url="images/nadir.png"
ath="0"
atv="90"
distorted="true"
scale="1.0"
rotate="0.0"
rotatewithview="false"
onclick="switch(rotatewithview); invalidatescreen();"
/>

What am I doing wrong?

fellipe

Trainee

  • "fellipe" started this thread

Posts: 67

Location: Brazil

Occupation: Photographer

  • Send private message

2

Saturday, June 12th 2010, 5:51pm

Got it's working now... I was using the kprotectec (embedded) krpano.swf :(
my fault.

fellipe

Trainee

  • "fellipe" started this thread

Posts: 67

Location: Brazil

Occupation: Photographer

  • Send private message

3

Saturday, June 12th 2010, 5:58pm

IF I want to link it to a url I insert this code:

onclick="openurl(http://krpano.com/docu/actions/#openurl,_blank);

but nothign happens when I click the nadir logo :(

4

Saturday, June 12th 2010, 6:04pm

Here's what I use.

EDITED:

<hotspot name="nadirlogo"
url="images/nadir.png"
keep="true"
ath="0"
atv="90"
distorted="false"
zoom="false"
scale="2"
rotate="0.0"
rotatewithview="false"
onclick="action(logo)"
/>
<events onxmlcomplete=""
onviewchange="if(hotspot[nadirlogo].rotatewithview, set(hotspot[nadirlogo].rotate,get(view.hlookat)) );"
/>

<action name="logo">
oninterrupt(break);
set(autorotate.enabled,false);
openurl(http://www.yourwebsitehere.com,_blank);"
</action>

This post has been edited 1 times, last edit by "Jarredja" (Jan 7th 2011, 10:47pm)


fellipe

Trainee

  • "fellipe" started this thread

Posts: 67

Location: Brazil

Occupation: Photographer

  • Send private message

5

Saturday, June 12th 2010, 6:13pm

Thanks Jarredja *thumbup*

6

Thursday, January 6th 2011, 11:33am

Nadir logo - swf

Hi all small prob ^^ help me please

Nadir image (Vector graphics) in .swf ---- pixellation . (logo.swf) with distorted="true"

Quoted


<hotspot name="nadirlogo"
url="logo.swf"
width="300" height="300"
ath="0" atv="90"
distorted="true"
details="8"
scale="2"
rotate="0.0"
rotatewithview="true"
onclick=""
visible="true" enabled="false" usecontentsize="false" handcursor="true" capture="true" children="true"
/>


thank you for your reply *cry*

This post has been edited 1 times, last edit by "Marty McFly" (Jan 7th 2011, 6:57pm)


7

Friday, January 7th 2011, 6:32pm

I think this note found in the documentation discusses your issue.

Quoted


rotate hotspot[name].rotate Number 0.0
Rotation of the hotspot element in degrees.

Note - this setting should NOT be used together with distorted="true"!



Jarred

8

Friday, January 7th 2011, 7:03pm

Thank you for your help jarredja. ;-)
but i take the code in the demo of Klaus in the exemple (nadir-logo)

Quoted

<!-- nadir logo (distored hotspot) -->
<hotspot name="nadirlogo"
url="krpano-roundlogo.png"
ath="0"
atv="90"
distorted="true"
scale="1.0"
rotate="0.0"
rotatewithview="false"
onclick="switch(rotatewithview); invalidatescreen();"
/>
I have a problem with .swf file - pixellation . *blink* -- jpg or png work fine *blink*

9

Friday, January 7th 2011, 7:48pm

Oops, sorry. I came across that and thought it might help. What is the size of your logo.swf? Is it the same size as the .png file you are using?

10

Friday, January 7th 2011, 9:58pm

Hi,

that's the error:

you named your hotspot "nadir":
<hotspot name="nadir"
but in the "onviewchange" event you are using the name "nadirlogo" to address the hotspot:
onviewchange="if(hotspot[nadirlogo].rotatewithview, set(hotspot[nadirlogo].rotate,get(view.hlookat)) );"

best regards,
Klaus

11

Friday, January 7th 2011, 10:46pm

Well, thanks for catching my error here, I will edit it above.

But do you know what's Marty's problem? He seems to be using the code directly from your example and his logo.swf is having pixalation issues.