Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 11. Mai 2010, 17:00

No display on iphone with iphone license

Hello,

what a great thing to make krpano works on iphone but i still have a problem.
I bought iphone license following each step to perform it correctly.
Upload all the files following instructions but on my iphone screen remain the error message saying me to download flash !

I had a existing pano working on computers but when i modify it in order to work with iphone i still have this error message.

Here's the link to the pano

http://www.vue-360.fr/panosph/om/om_real_madrid/om_real.html


The xml file can be find replacing html by xml.
Can you please tell me where there must be a mistake.
I have uploaded in the same folder than krpano.swf, the swfkrpano.js, krpanoiphone.js and krpanoiphone.license.js

Thanks for your help because i really need to make this work for one of my customer who was waiting for it.

Best regards.

Stephane

2

Dienstag, 11. Mai 2010, 17:22

in your html, replace

<script type="text/javascript">


// <![CDATA[
if (typeof(deconcept) !== 'undefined' && deconcept.SWFObjectUtil.getPlayerVersion().major >= 6)
{
var so = new SWFObject("krpano.swf", "krpanoSWFObject", "100%", "100%", "9.0.28","#000000");
so.addParam("allowFullScreen","true");
so.addVariable("pano", "om_real.xml");
so.useExpressInstall("expressinstall.swf");
so.setAttribute("xiRedirectUrl", window.location);
if ( so.write("krpano") ) { var mousewheelfixes = new SWFkrpanoMouseWheel(so); }
}
else
{
document.getElementById("krpano").innerHTML = '<table width="100%" height="100%"><tr valign="middle"><td><center>ERROR:<br><br>Adobe Flash Player 9 needed<br><br><br><a href="http://www.adobe.com/go/getflashplayer/" target="_blank"><IMG SRC="http://www.macromedia.com/images/shared/download_buttons/get_flash_player.gif" BORDER="1"></a><br>...click here to download...<br><br><br><br></center></td></tr></table>';
}
// ]]>
</script>




with



<script type="text/javascript">

var swf = createswf("krpano.swf");
swf.addVariable("xml","om_real.xml");
swf.embed("krpanoDIV");

</script>

3

Dienstag, 11. Mai 2010, 17:43

Thanks for your help i did that yet when i was trying to make it work but as you can see when i do that there's no display on my computer and no more on my iphone.

Can you test and tell me if it works with you ?

I really don't understand why it doesn't work.

Thanks for help me.

4

Dienstag, 11. Mai 2010, 17:55

oops, your div name has changed too

<div id="krpano">

change to


<div id="krpanoDIV">

or change it in the script instead.

5

Dienstag, 11. Mai 2010, 18:01

Hi,

I just want to write the same:
the name of the div and
<div id="krpano">

change to

<div id="krpanoDIV">

btw - it would be better to use the complete html from the template/example,
because without the "viewport" and "apple" meta tags the scaling can be
wrong on the iphone/ipad devices,

best regards,
Klaus

6

Dienstag, 11. Mai 2010, 18:14

So I did this modif, and if i can see the pano om my computer the error message came back on my iphone.
I really don't understand it seems to be easy to do and i can't manage to make it work.
I replace it in the html and replace the swfkrpano.js with the one containing the krpanoDIV but nothing better.

Sorry for boring but i really don't understand what's the problem.

Stephane

7

Dienstag, 11. Mai 2010, 18:26

As you can see i used the complete form from the html example.

Nothing better on my iphone just the error message written bigger than before *g*

But i don't really know how to get it works ! *cry*

Stephane

8

Dienstag, 11. Mai 2010, 18:39

the original swfkrpano.js you had was correct. this one does't seem to have the iPhone function


the first lines in the swfkrpano.js should be


swfkrpano.js
krpano 1.0.8.10

usage informations:
http://krpano.com/docu/swfkrpanojs/

9

Dienstag, 11. Mai 2010, 18:43

I made some test :

I use "make pano" droplet to create a version of this pano, i upload it and it works perfectly.
you can see it here
http://www.vue-360.fr/panosph/om/mobile_om_real/om_real.html


So I decided to replace the original files of the first version of the pano i submitted to you with the ones created by the droplet "make pano"
But it doesn't work, do you think the problem may come from a compatibility with the om_real.xml original file which contain sound, plugin...

Do we have to make simple pano or a dedicated version without plugin, sound and hotspot keeping in mind that they'll not work on iphone to make them work correctly on iphone ?

Thanks for your help ;)

10

Dienstag, 11. Mai 2010, 18:45

the original swfkrpano.js you had was correct. this one does't seem to have the iPhone function


the first lines in the swfkrpano.js should be


swfkrpano.js
krpano 1.0.8.10

usage informations:
http://krpano.com/docu/swfkrpanojs/
So when i replace this one by the one you say as i did first i still have only a black screen as you can see.
I'm going crazy

Stephane

11

Dienstag, 11. Mai 2010, 19:01

Try this please.

Delete the copy of swfkrpano.js from your server on the nonworking one. download the working copy from the other pano and then upload that copy of swfkrpano.js to the nonworking copy. I believe it will work. The one that is stored online at the moment on the not working one seems different.

Edit: Maybe that wasn't it. I see the script I was missing before yet it doen't work.

Perhaps there is a conflict somewhere. Save a copy and start deleting until it works. If everything matches except for the additional script, I have no idea why it will not work.

12

Dienstag, 11. Mai 2010, 19:11

Many thanks for your help jarredja but it doesn't work better.

I'm really disappointed because it really seems to be simple to work correctly. :(


Klaus any idea to solve this ?

13

Dienstag, 11. Mai 2010, 19:13

good luck.

Final thoughts. The non working one has larger images. Maybe change to 480 x 480 to test. The tablet info is in the xml for the working pano.

Edit: I tried both and still got a working pano.




Anyway, good luck.

14

Dienstag, 11. Mai 2010, 19:26

I tried this but no more effect.

Always error message on the iphone :(

Does it means that it'll be impossible or really hard to make it work with old pano ?

15

Dienstag, 11. Mai 2010, 19:39

Hi,

the swfkrpano.js that is currently on your server is the old one,
you need to use that from the 1.0.8.10 package!

after changing it - clear all your browser caches to be sure that the new one will be loaded!

best regards,
Klaus

16

Dienstag, 11. Mai 2010, 19:45

I took his xml and added my pano into it. I was able to get it working when I removed the context menu block completely and also the two plugins for the sound. Of course, I didn't actually have those plugins installed on my server so that may be part of the issue.


see below.

<plugin name="playbutton" url="on1.png"
keep="false"
visible="true" enabled="true" handcursor="true" capture="true" children="true"
zorder="1"
alpha="0.85" blendmode="normal"
smoothing="true"
origin="righttop" edge="righttop"
x="10" y="25"
width="30" height="30"
scale="1"
onloaded=""
onloaded=""
onover=""
onhover="showtext(Activez le son);"
onout=""
ondown=""
onup=""
onclick="playsound(mymusik,auxarmes2.mp3,loops);"
/>

<plugin name="stopbutton" url="off1.png"
keep="false"
visible="true" enabled="true" handcursor="true" capture="true" children="true"
zorder="1"
alpha="0.85" blendmode="normal"
smoothing="true"
origin="righttop" edge="righttop"
x="10" y="60"
width="30" height="30"
scale="1"
onloaded=""
onover=""
onhover="showtext(Arrêtez le son);"
onout=""
ondown=""
onup=""
onclick="stopsound(mymusik);"
/>

<!-- right-click context menu to change the viewing settings -->
<contextmenu>
<item caption="Création : VUE-360.FR" onclick="openurl(http://www.vue-360.fr,_blank);"/>
<item caption="FULLSCREEN"/>
<item caption="vue normale" onclick="action(rectview);" separator="true"/>
<item caption="vue fisheye" onclick="action(fisheyeview);"/>
<item caption="vue architecturale" onclick="action(architectural);"/>

<item caption="vue stereographique" onclick="action(stereofisheyeview);"/>
<item caption="vue petite planete" onclick="action(littleplanet);"/>
</contextmenu>

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Jarredja« (12. Mai 2010, 17:54)


17

Mittwoch, 12. Mai 2010, 17:48

As told by Klaus here Iphone license Bug or problem report, I test my xml to see if there's no syntax error that iphone could reject, and i can see there was one. I made the correction, upload the xml and finally it works fine.

Thanks to Jarredja and Klaus for your help. *thumbsup* *thumbsup*

I think i'll be more carreful to all my xml syntax in order to work correctly on iphone !

Stephane