You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Sunday, July 12th 2009, 6:10pm

Gut, alles klar.

Jetzt bleibt nur noch die Frage, warum ein jpg ohne Farbprofil in Photoshop anders dargestellt wird als in einem Browser (bzw. in einem Programm, was gar keine Farbprofile "interpretieren" kann).

In solch einem Fall sollten eigentlich beide Darstellungen identisch sein.
Schließlich kann man in Photoshop ja explizit "für's Web" abspeichern, d.h. konvertieren in sRGB und abspeichern ohne Profil (wie gehabt)...

Man korrigiere mich bitte, falls nötig... ;-)

Theo

22

Sunday, July 12th 2009, 6:33pm

man müsst die Bilder glaub nach der ktransformation in Photoshop öffnen in sRGB konvertieren und dann per "Für Web speichern" mit eingebettetem sRGB Profil speichern.
Dann sehn die Farben auch im Browser so aus, wie die von der Kamera erstellten und im RAW-Converter bearbeiteten Einzelfotos.

23

Sunday, July 12th 2009, 6:57pm

jetzt nochmal der ultimative TEst :)
Und zwar ein Bild aus Autopano gerendert.
Dieses Bild im Browser ist blass, in Photoshop richtig.
Das Bild kat KEIN Farbprofil, ich konvertiere das Bild also in sRGB und speichere.
So, Bild nun sowohl im Browser, als auch in Photoshop richtig.
Nun zieh ich dieses Bild auf ktransform und die ausgegebenen kubischen Bilder sind im Browser wieder blass und wenn ich schaue, haben sie das Farbprofil verloren, obwohl es konvertiert/umgewandelt wurde ins Farbprofil.
Also liegts doch an krpano, dass die Bilder, obwohl sie ins Farbprofil konvertiert wurden, dieses nach der Umwandlung wieder verlieren.


Mein Workflow nun:
-Bild rendern aus Autopano
-in Photoshop öffnen es wird dort in den richtigen Farben angezeigt und ich bearbeite noch Farbsättigung und Kontrast (KEINE Profilumwandlung)
-sphärisches Bild wird in kubische Projektion umwenandelt (diese Bilder haben immernoch kein Profil und sind im Browser blass und in Photoshop logischerweise in den richtigen Farben, da der PS-Arbeitsfarbraum bei mir sRGB ist und die Bilder automatisch in diesen Farbraum umgewandelt werden
-und nun habe ich einen Batch-Prozess angelegt, der diese kubische Bilder automatisch in das sRGB Profil konvertiert

Diese konvertierung allerdings erst ganz am Schluss bei den Bildern, die für krpano dann wirklich verwendet werden. Davor arbeite ich immer mit den Bildern ohne Profil, da diese durch ktransform sowieso verloren gehen, in PS aber immer richtig angezeigt werden, da der Arbeitsfarbraum sRGB ist.

So funktionierts nun, und klingt für mich auch ziemlich logisch :)
bis eben Klaus ktransform so umprogrammiert hat, dass das Profil anschließend wieder eingebettet wird, bzw. die Bilder wieder ins Farbprofil konvertiert werden.

24

Monday, July 13th 2009, 10:10am

Meiner bescheidenen Meinung nach befindest Du dich auf einem kompletten Irrweg.
Klingt ein bißchen hart, ist aber wirklich nicht böse gemeint.

Bezüglich der Bilddatei bleibt es dabei:
Farbrichtige Version für die Webansicht in sRGB konvertieren und fertig ist die Laube.

Punkt.

Es liegt wirklich an was ganz anderem.
Ich tippe jetzt mal: Du arbeitest auf einem Mac, stimmt`s?
Falls ja, dann schau Dir mal diese beiden Links an (bevor ich hier Romane schreibe...):

1) Why color changes when Save for Web

2) Color and gamma settings for print and web


Viel Spaß... ;-)

Theo

25

Monday, July 13th 2009, 11:59am

Hallo Marc,

fein, dass du ans ziel gekommen bist, nur ACHTUNG:

Quoted

Das Bild kat KEIN Farbprofil, ich konvertiere das Bild also in sRGB und speichere.
... um ein Bild in einen Zielfarbraum (hier sRGB) zu konvertieren, MUSS ein Quellfarbraum bekann sein oder angenommen ( UND zugewiesen) werden. Wenn Du hier keinen eingebetteten colortag hast, dir aber bekannt ist, dass das Bild aus zB Adobe-RGB Farbraum kommt, dann musst du den vorher zuweisen, weil du sonst wieder undefiniert (= nicht reproduzierbar) arbeitest.
lg,
Oliver
best regards from www.PanAustria.com

26

Monday, July 13th 2009, 7:08pm

okay, danke euch, ich seh schon, besser ist, ich les mich jetzt erstmal ordentlich ins Color Management ein, bevor ich mit meinem Halbwissen hier weiterschreibe :) Denn da kommen wir nicht auf einen grünen Zweig, weil ich das ganze (noch) anderes sehe, auf Grund eben, dass ich das ganze recht oberflächlich betrachte.
Aber du hast Recht, ich sitz hier am Mac und was ich schon gelesen habe, wird am Mac bei Bildern ohne Farbprofil beim Betrachten automatisch das Monitor-Profil zugewiesen und am Windows (Vista) das sRGB...
Mein nächster Schritt somit in den nächsten Tagen in die Bibliothek - Buchtipps durch Erfahrungen sind gerne gesehen :)

27

Wednesday, July 15th 2009, 1:42pm

... um ein Bild in einen Zielfarbraum (hier sRGB) zu konvertieren, MUSS ein Quellfarbraum bekann sein oder angenommen ( UND zugewiesen) werden. Wenn Du hier keinen eingebetteten colortag hast, dir aber bekannt ist, dass das Bild aus zB Adobe-RGB Farbraum kommt, dann musst du den vorher zuweisen, weil du sonst wieder undefiniert (= nicht reproduzierbar) arbeitest.
lg,
Oliver
richtig, das ist die Lösung!

das Originaltiff hat im Header den Adobe-RGB Farbraum angegeben,

diese Information wird aber (noch!) nicht in die erzeugten TIFF Dateien geschrieben,
die TIFFs haben also keinen definierten Farbraum,

ich schätze einmal die meisten Grafikbearbeitungsprogramme mit Farbverwaltung, nehmen dann in einem solchen Fall, sRGB als Standardfarbraum an,

und das ist das Problem - es sind Adobe-RGB Daten - es wird aber angenommen es sind sRGB Daten

Schöne Grüße,
Klaus

KlausR

Beginner

Posts: 4

Location: Löhne

  • Send private message

28

Monday, February 8th 2010, 10:20pm

Hallo,
bei mir tritt das Problem der flauen Farben ebenfalls auf. Ich möchte kurz mal beschreiben, wie ich bisher vorgegangen bin.

Als erstes habe ich ein Bild von Aperture eine Arbeitskopie erstellt. Dieser habe ich den Profiel sRGB zugewiesen.
Anschließend habe die Teilbilder mit Tool Marke Pano (Flat) droplet erzeugt. Abschließend habe ich dann den Bildern mit Hilfe des Automators und den ColourSyns-Dienstprogramm wieder das ursprüngliche Profil zugewiesen.
Laut den oben beschriebenen Lösungswegen müssten meine Bilder nun doch wieder in den ursprünglichen Farben und Kontrasten angezeigt werden.? Oder habe ich doch etwas falsch verstanden. *question*

Schöne Güße
Klaus

29

Monday, February 8th 2010, 10:29pm

Hi,

die Ursprüngsbilder müssen bereits vor dem MAKE PANO (###) im sRGB Farbraum vorliegen,
das Profil muss nicht nur zugewiesen, sondern es muss nach sRGB konvertiert werden,

nachträgliche zugewiesene Farbprofile werden in Flash ebenfalls ignoriert,
fürs Web deshalb am besten nur sRGB,

Schöne Grüße,
Klaus