You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, February 6th 2009, 3:28pm

INPUTERROR: not all cube sides found:

Hello!

I have recently discovered this nice program but I have a problem. When I drag and drop the 6 tiles to the alias i get this error in terminal.


INPUTERROR: not all cube sides found:
-left=pano1_left.jpg (ok)
-front=ERROR - not found
-right=ERROR - not found
-back=ERROR - not found
-up=ERROR - not found
-down=ERROR - not found
INPUTERROR: not all cube sides found:
-left=ERROR - not found
-front=pano2_front.jpg (ok)
-right=ERROR - not found
-back=ERROR - not found
-up=ERROR - not found
-down=ERROR - not found
INPUTERROR: not all cube sides found:
-left=ERROR - not found
-front=ERROR - not found
-right=pano3_right.jpg (ok)
-back=ERROR - not found
-up=ERROR - not found
-down=ERROR - not found
INPUTERROR: not all cube sides found:
-left=ERROR - not found
-front=ERROR - not found
-right=ERROR - not found
-back=pano4_back.jpg (ok)
-up=ERROR - not found
-down=ERROR - not found
INPUTERROR: not all cube sides found:
-left=ERROR - not found
-front=ERROR - not found
-right=ERROR - not found
-back=ERROR - not found
-up=pano5_up.jpg (ok)
-down=ERROR - not found
INPUTERROR: not all cube sides found:
-left=ERROR - not found
-front=ERROR - not found
-right=ERROR - not found
-back=ERROR - not found
-up=ERROR - not found
-down=pano6_down.jpg (ok)
runtime: 0.000000 sec
press enter to continue...

It looks lite it finds them but not at the same time. I´m a beginner with krpanotool and the tiles where made with Ptmac. Maybe I should use another program to make cubes. If that is the problem. Do you have any suggertions.

Regards

Per *thumbsup*

Tuur

Master

Posts: 2,200

Location: Netherlands

Occupation: Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Friday, February 6th 2009, 4:05pm

you have to make the tiles with krpano tools- sphere to cube droplet


goodluck

tuur *thumbsup*

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

3

Saturday, February 7th 2009, 3:51am

what are the file names being used?

4

Monday, February 9th 2009, 11:34am

Hi,

when kmakemultires gets a bundle of files it tries to find
the files which are belong together,
(because you can also drop a more than one pano at once)

for cubical images - is looks for a "base"-filename followed
by a suffix like "_l,_f,_r,.." or "left,right,..."

but your filenames, are look like this:

pano1_left.jpg
pano2_front.jpg
pano3_right.jpg
pano4_back.jpg
pano5_up.jpg
pano6_down.jpg

the identified basenames are "pano1", "pano2", "pano3", ...
so kmakemultires thoughts they are different panos,

at the moment to get it working, you need to rename the files,
e.g. to this:

pano1_left.jpg
pano1_front.jpg
pano1_right.jpg
pano1_back.jpg
pano1_up.jpg
pano1_down.jpg

I didn't know that there are programs with this naming order,
but I will add a auto detection also for this naming convention,

best regards,
Klaus

machart

Trainee

Posts: 135

Location: Ostfriesland

  • Send private message

5

Monday, February 9th 2009, 5:58pm

Correctly named but error

hi!
i did cubic sides using SPHERE to CUBE, the files are named as expected, but kmakemultires droplet is not able to work:

Source code

1
INPUTERROR: not a pano image: Pink_Boogie5_b.tif (2546x2546)INPUTERROR: not all cube sides found: -left=Pink_Boogie5_l.tif (ok) -front=Pink_Boogie5_f.tif (ok) -right=Pink_Boogie5_r.tif (ok) -back=ERROR - not found -up=Pink_Boogie5_u.tif (ok) -down=Pink_Boogie5_d.tif (ok)



i checked all files, they are ok... *confused*
__close to the rainbow__
_D300S|Sunwayfoto|iMaci7|PM|APP|KRP_
www.panographie.net

6

Wednesday, February 11th 2009, 12:37am

Hi,

sorry, this is the same problem here, the auto detection of the files
which belong together fails here,

the first "_B" in Pink_Boogie5_b.tif was detect wrong,
if you will rename the files (e.g. to PinkBoogie5_*.tif), they will work,

but I fixed this error now, the next version will habe the problem anymore

best regards,
Klaus

machart

Trainee

Posts: 135

Location: Ostfriesland

  • Send private message

7

Wednesday, February 11th 2009, 3:04pm

hallo, klaus!
vielen dank für die hilfe! hat gefunzt...
was mich allerdings stutzig macht:
Pink_Boogie4 (sowie 3, 9 und 10) funktionieren... *huh*
__close to the rainbow__
_D300S|Sunwayfoto|iMaci7|PM|APP|KRP_
www.panographie.net

8

Wednesday, February 11th 2009, 9:07pm

es kommt auf die Reihenfolge der Bilder an, ob es richtig erkannt wird,
wenn das "_b" Bild zuerst kommt, wird es falsch erkannt,
aber wie gesagt, in der nächsten Version ist das ausgebessert

Schöne Grüße,
Klaus